ES2016 preset

只编译 ES2016 的内容(到 ES2015)

如果你想保持最新版本,请使用 env preset

这个 preset 依赖以下这些插件:

基本配置 (使用 CLI)

欲了解更多,请查看 cli 的设置页面及其使用相关文档.

安装 CLI 及该 preset

npm install --save-dev babel-cli babel-preset-es2016

为 preset 创建 .babelrc 配置文件

echo '{ "presets": ["es2016"] }' > .babelrc

创建要运行的文件

echo 'console.log(2 ** 3)' > index.js

运行它

./node_modules/.bin/babel-node index.js

安装

npm install --save-dev babel-preset-es2016

使用

通过 .babelrc (推荐)

.babelrc

{
  "presets": ["es2016"]
}

通过 CLI

babel script.js --presets es2016

通过 Node API

require("babel-core").transform("code", {
  presets: ["es2016"]
});