ES2015 preset

只会将 ES2015 编译为 ES5

如果你想保持最新版本,请使用 env preset

这个 preset 中包含以下插件:

基础设置 (使用 CLI)

可以查看 React 文档中的 快速配置页

欲了解更多,请查看 cli 配置以及用法文档。

安装 CLI 和该 preset

npm install --save-dev babel-cli babel-preset-es2015

为 preset 创建 .babelrc 配置文件

echo '{ "presets": ["es2015"] }' > .babelrc

创建要运行的文件

echo 'console.log([1, 2, 3].map(n => n + 1))' > index.js

执行该文件

./node_modules/.bin/babel index.js

安装

npm install --save-dev babel-preset-es2015

使用

通过 .babelrc (推荐)

.babelrc

{
  "presets": ["es2015"]
}

通过 CLI

babel script.js --presets es2015

通过 Node API

require("babel-core").transform("code", {
  presets: ["es2015"]
});

选项

loose

boolean, 默认 false.

为该预设中允许它们的任何插件启用“loose”转换.

modules

"amd" | "umd" | "systemjs" | "commonjs" | false, 默认 "commonjs".

启用将es6模块语法转换为另一个模块类型.

将其设置为false将不会转换任何模块.

spec

boolean, 默认false.

为该预设中允许它们的任何插件启用“spec”转换.